Ccna Lab Manual

download Ccna Lab Manual

of 109

description

Ccna Lab Manual

Transcript of Ccna Lab Manual

  • 5/23/2018 Ccna Lab Manual

    1/109

    CCNALab Guide

  • 5/23/2018 Ccna Lab Manual

    2/109

    Cisco IOS Introduction

    General Reading:-

    System Architecture

    Like a computer, a router has a CPU that varies in performance and capabilities depending on the

    router platform. Two examples of processors that Cisco uses are the Motorola 68030 and theOrion/R4600. The Cisco IOS software running in the router requires the CPU or processor to makerouting and bridging decisions, maintain routing tables, and other system management functions.The CPU must have access to data in memory to make decisions or to get instructions.

    There are usually four types of memory on a Cisco router:

    ROMROM is generally the memory on a chip or multiple chips. It is available on a router'sprocessor board. It is read-only, which means that data cannot be written to it. The initial softwarethat runs on a Cisco router is called the bootstrap software and is usually stored in ROM. Thebootstrap software is invoked when the router boots up.

    FlashFlash memory is located on a processor board SIMM but can be expanded using PCMCIA

    (removable) cards. Flash memory is most commonly used to store one or more Cisco IOS softwareimages. Configuration files or system information can also be copied to Flash. On some high-endsystems, Flash memory is also used to hold bootstrap software.

    RAMRAM is very fast memory that loses its information when the system is restarted. It is used inPCs to store running applications and data. On a router, RAM is used to hold IOS system tables andbuffers. RAM memory is basically used for all system operational storage requirements.

    NVRAMOn the router, NVRAM is used to store the startup configuration. This is the configurationfile that IOS reads when the router boots up. It is extremely fast memory and is persistent acrossreboots.

    Although CPU and memory are required components to run IOS, a router must also have various

    interfaces to allow packet forwarding. Interfaces are input and output connections to the router thatcarries data that needs to be routed or switched. The most common types of interfaces are Ethernetand serial. Similar to the driver software on a computer with parallel ports and USB ports, IOS hasdevice drivers to support these various interface types. All Cisco routers have a console port thatprovides an EIA/TIA-232 asynchronous serial connection. The console port can be connected to acomputer's serial connection to gain terminal access to the router. Most routers also have anauxiliary port that is very similar to the console port, but is typically used for modem connection forremote router management.

    Following Output shows the console output of a new Cisco 3640 router that has just been started.Notice the processor, interface, and memory information that is listed.

    System Bootstrap, Version 11.1(20)AA2, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)Copyright (c) 1999 by Cisco Systems, Inc.C3600 processor with 98304 Kbytes of main memoryMain memory is configured to 64 bit mode with parity disabled

    program load complete, entry point: 0x80008000, size: 0xa8d168Self decompressing the image :##################################################################################################################### [OK]

    Restricted Rights Legend

  • 5/23/2018 Ccna Lab Manual

    3/109

    Use, duplication, or disclosure by the Government is

    subject to restrictions as set forth in subparagraph

    (c) of the Commercial Computer Software - Restricted

    Rights clause at FAR sec. 52.227-19 and subparagraph

    (c) (1) (ii) of the Rights in Technical Data and Computer

    Software clause at DFARS sec. 252.227-7013.

    Cisco Systems, Inc.

    170 West Tasman Drive

    San Jose, California 95134-1706

    Cisco Internetwork Operating System Software

    IOS (tm) 3600 Software (C3640-IS-M), Version 12.2(10), RELEASE SOFTWARE (fc2)

    Copyright (c) 1986-2002 by Cisco Systems, Inc.

    Compiled Mon 06-May-02 23:23 by pwade

    Image text-base: 0x60008930, data-base: 0x610D2000

    cisco 3640 (R4700) processor (revision 0x00) with 94208K/4096K bytes of memory.

    Processor board ID 17746964

    R4700 CPU at 100Mhz, Implementation 33, Rev 1.0

    Bridging software.

    X.25 software, Version 3.0.0.

    SuperLAT software (copyright 1990 by Meridian Technology Corp).

    5 Ethernet/IEEE 802.3 interface(s)

    1 Serial network interface(s)

    DRAM configuration is 64 bits wide with parity disabled.

    125K bytes of non-volatile configuration memory.

    8192K bytes of processor board System flash (Read/Write)

    16384K bytes of processor board PCMCIA Slot0 flash (Read/Write)

    --- System Configuration Dialog ---

    Would you like to enter the initial configuration dialog? [yes/no]:

    When a new router is first started, IOS runs an autoinstall process wherein the user is prompted to

    answer a few questions. IOS then configures the system based on the input provided. After initialsetup, the configuration is most commonly modified using the command-line interface (CLI). Otherways of configuring the router include HTTP and network management applications

    Cisco IOS has three command modes, each with access to different command sets:

  • 5/23/2018 Ccna Lab Manual

    4/109

    User modeThis is the first mode a user has access to after logging into the router. The usermode can be identified by the > prompt following the router name. This mode allows the user toexecute only the basic commands, such as those that show the system's status. The system cannotbe configured or restarted from this mode.

    Router>

    Privileged modeThis mode allows users to view the system configuration, restart the system,

    and enter configuration mode. It also allows all the commands that are available in user mode.Privileged mode can be identified by the # prompt following the router name. The user mode enablecommand tells IOS that the user wants to enter privileged mode. If an enable password or enablesecret password has been set, the user needs to enter the correct password or secret to be grantedaccess to privileged mode. An enable secret password uses stronger encryption when it is stored inthe configuration and, therefore, is safer. Privileged mode allows the user to do anything on therouter, so it should be used with caution. To exit privileged mode, the user executes the disablecommand.

    Router#

    Configuration modeThis mode allows users to modify the running system configuration. To enterconfiguration mode, enter the command configure terminal from privileged mode. Configurationmode has various submodes, starting with global configuration mode, which can be identified by the(config)# prompt following the router name. As the configuration mode submodes changedepending on what is being configured, the words inside the parentheses change. For example,when you enter interface configuration submode, the prompt changes to (config-if)# following therouter name. To exit configuration mode, the user can enter end or press Ctrl-Z.

    Router(config)#

    Terminal Server

    Now days it is very difficult to use console cable and access multiple devices as routers andswitched which we configure are placed in datacenter, to overcome this problem we use terminalserver. This is a single point of management device.

    A terminal or comm server commonly provides out-of-band access for multiple devices. A terminalserver is a router with multiple, low speed, asynchronous ports that are connected to other serial

    devices, for example, modems or console ports on routers or switches.

    The terminal server allows you to use a single point to access the console ports of many devices. Aterminal server eliminates the need to configure backup scenarios like modems on auxiliary ports forevery device. You can also configure a single modem on the auxiliary port of the terminal server, toprovide dial-up service to the other devices when network connectivity fails.

    Below is the pictorial scenario which shows the working of terminal server

  • 5/23/2018 Ccna Lab Manual

    5/109

    Task 1Telnet to CCNA Terminal Server at IP address 172.16.50.88

    Solution:

    In Linux Base system such as Ubuntu go to applications then accessories and clickon terminal and type telnet 172.16.50.88

    For Windows machine go to run and type telnet 172.16.50.88

    Task 2After you telnet into terminal server it will ask you for username and password,

    use username:student and password:student

    Solution:

    telnet 172.16.50.88

    +--------------------------------------------------------------------+

    | Following commands are available for use at privilege 0 |

    | 1).Show Host |

    | 2).Show Sessions |

    | 3).Show Users |

    | 4).Clear Line |

    | 5).Disconnect |

    | |

    | Following CCNA Racks Can be Accessed From This Terminal :- |

    | 1).CCNA-Rack1 |

    | 2).CCNA-Rack2 |

  • 5/23/2018 Ccna Lab Manual

    6/109

    | 3).CCNA-Rack3 |

    | 4).CCNA-Rack4 |

    | 5).CCNA-Rack5 |

    | 6).CCNA-Rack6 |

    | 7).CCNA-Rack7 |

    | 8).CCNA-Rack8 |

    | 9).CCNA-Rack9 |

    | 10).CCNA-Rack10 |

    +--------------------------------------------------------------------+

    ********************************************************************

    * WELCOME TO ACIT Bangalore *

    * YOU ARE CONNECTED TO CCNA-TERMINAL 88 *

    ********************************************************************

    User Access Verification

    Username: student

    Password:

    CCNA_Term#

    Task 3use show host commands to see the available racks.

    Solution:

    CCNA_Term#show host

    Default domain is not set

    Name/address lookup uses static mappings

    Codes: UN - unknown, EX - expired, OK - OK, ?? - revalidate

    temp - temporary, perm - permanent

    NA - Not Applicable None - Not defined

    Host Port Flags Age Type Address(es)

    Rack1-R1 1026 (perm, OK) 64 IP 128.0.0.2

    Rack1-R3 1028 (perm, OK) 84 IP 128.0.0.2

    Rack1-SW1 1029 (perm, OK) 84 IP 128.0.0.2

    Rack1-SW2 1030 (perm, OK) 84 IP 128.0.0.2

    ..

    Task 4Now access device rack1-r1

    Solution:

  • 5/23/2018 Ccna Lab Manual

    7/109

    CCNA_Term#rack1-r1

    Translating "rack1-r1"

    Trying Rack1-R1 (128.0.0.2, 1026)... Open

    % Please answer 'yes' or 'no'.

    Would you like to enter the initial configuration dialog? [yes/no]:no

    Press RETURN to get started!

    Router>

    (Note:-At this point we are in device R1 of rack1)

    Task 5Lock the session of R1 and come back to terminal server by pressingCTRL+SHIFT+6 X

    Solution:

    Router>

    CCNA_Term#

    Task 6Now open rack1-r2, rack1-r3, rack1-sw1 and rack1-sw2

    Solution:

    CCNA_Term#rack1-r2

    Translating "rack1-r2"

    Trying Rack1-R2 (128.0.0.2, 1027)... Open

    Press RETURN to get started!

    Router>

    CCNA_Term#rack1-r3

    Translating "rack1-r3"

    Trying Rack1-R3 (128.0.0.2, 1028)... Open

    Press RETURN to get started!

    Router>

    CCNA_Term#rack1-sw1

    Translating "rack1-sw1"

    Trying Rack1-SW1 (128.0.0.2, 1029)... Open

    Press RETURN to get started!

    switch>

    CCNA_Term#rack1-sw2

    Translating "rack1-sw2"

    Trying Rack1-SW2 (128.0.0.2, 1030)... Open

    Press RETURN to get started!

    switch>

    Task 7Go back to Terminal Server and check the sessions which you have opened bypressing CTRL+SHIFT+6 X

  • 5/23/2018 Ccna Lab Manual

    8/109

    Solution:

    CCNA_Term#show sessions

    Conn Host Address Byte Idle Conn Name

    1 rack3-r1 128.0.0.2 162 8 rack3-r1

    2 rack3-r2 128.0.0.2 0 0 rack3-r2

    3 rack3-r3 128.0.0.2 0 0 rack3-r34 rack3-sw1 128.0.0.2 39 0 rack3-sw1

    * 5 rack3-sw2 128.0.0.2 0 0 rack3-sw2

    (Note:-In above output you can see that we have opened 5 session. Automatically connectionnumbers are assigned to every session. So next time if you want to access R1 then we dont haveto press rack1-r1 again it can be simply accessed by pressing its current connection number i.e. 1.The Star before 5 shows the current active connection)

    Task 8on R1,R2,R3,SW1,SW2 Assign hostname R1,R2,R3,SW1,SW2 respectively

    Solution:

    CCNA_Term#1

    [Resuming connection 1 to rack1-r1 ... ]

    Router>enable

    Router#config t

    Enter configuration commands, one per line. End with CNTL/Z.

    Router(config)#hostname R1

    R1(config)#

    CCNA_Term#2

    [Resuming connection 2 to rack1-r2 ... ]

    Router>enable

    Router#config t

    Enter configuration commands, one per line. End with CNTL/Z.

    Router(config)#hostname R2

    R2(config)#

    CCNA_Term#3

    [Resuming connection 3 to rack1-r3 ... ]

    Router>enable

    Router#config t

    Enter configuration commands, one per line. End with CNTL/Z.

    Router(config)#hostname R3

    R3(config)#

  • 5/23/2018 Ccna Lab Manual

    9/109

    CCNA_Term#4

    [Resuming connection 4 to rack1-SW1 ... ]

    Switch>enable

    Switch#config t

    Enter configuration commands, one per line. End with CNTL/Z.

    Switch(config)#hostname SW1

    SW1(config)#

    CCNA_Term#5

    [Resuming connection 5 to rack1-SW2 ... ]

    Switch>enable

    Switch#config t

    Enter configuration commands, one per line. End with CNTL/Z.

    Switch(config)#hostname SW2

    SW2(config)#

    Task 9Go to R1 and Check the available interfaces

    Solution:

    On R1:

    R1#show ip interface brief

    Interface IP-Address OK? Method Status ProtocolEthernet0/0 unassigned YES unset administratively down down

    Ethernet0/1 unassigned YES unset administratively down down

    Ethernet0/2 unassigned YES unset administratively down down

    Ethernet0/3 unassigned YES unset administratively down down

    Serial1/0 unassigned YES unset administratively down down

    Serial1/1 unassigned YES unset administratively down down

    Serial1/2 unassigned YES unset administratively down down

    Serial1/3 unassigned YES unset administratively down down

    (Note:-Above are the list of interfaces available on router R1 but it may vary as device to device)

  • 5/23/2018 Ccna Lab Manual

    10/109

    Task 9On R1 assign IP address 10.0.0.1 and use classful subnetmask to interface

    Ethernet 0/0 and verify your configuration.

    Solution:

    On R1:

    R1#

    R1#configure terminal

    Enter configuration commands, one per line. End with CNTL/Z.

    R1(config)#interface ethernet 0/0

    R1(config-if)#ip address 10.0.0.1 255.0.0.0

    R1(config-if)#no shutdown

    R1(config-if)#exit

    *Jul 1 00:37:53.867: %LINK-3-UPDOWN: Interface Ethernet0/0, changed state to

    up

    *Jul 1 00:37:54.871: %LINEPROTO-5-UPDOWN: Line protocol on InterfaceEthernet0/0, changed state to up

    R1(config)#exit

    R1#

    (Note:- We Can See that no shutdown command has been issued to start the interface. After

    issuing the command we can see that 2 log massages are appeared on the console, stating that link

    and line-protocol changed to up.)

    Verification:

    On R1:

    R1#

    R1#show ip interface brief

    Interface IP-Address OK? Method Status Protocol

    Ethernet0/0 10.0.0.1 YES manual up up

    Ethernet0/1 unassigned YES unset administratively down downEthernet0/2 unassigned YES unset administratively down down

    Ethernet0/3 unassigned YES unset administratively down down

    Serial1/0 unassigned YES manual administratively down down

    Serial1/1 unassigned YES unset administratively down down

    ...

    (Note:-In verification we can see that interface status and line protocol of interface Ethernet 0/0 is

    UP, also we can see that IP address which we assigned Is there, we should always consider a

    important note that every UP interface of router which has ip address is assigned defines one whole

    network, in this case interface Ethernet 0/0 defines the network 10.0.0.0 255.0.0.0, it can be verified

    with show ip route command, therefore we cannot give any ip from this network to any other

    interface of the this router.)

  • 5/23/2018 Ccna Lab Manual

    11/109

    R1#show ip route

    Codes: L - local, C - connected, S - static, R - RIP, M - mobile,

    B BGP , D - EIGRP, EX - EIGRP external, O OSPF

    IA - OSPF inter area , N1 - OSPF NSSA external type 1,

    N2 - OSPF NSSA external type 2 , E1 - OSPF external type 1,

    E2 - OSPF external type 2 , i - IS-IS, su - IS-IS summary,

    L1 - IS-IS level-1, L2 - IS-IS level-2 ,

    ia - IS-IS inter area, * - candidate default,

    U - per-user static route , o - ODR,

    P - periodic downloaded static route, + - replicated route

    Gateway of last resort is not set

    10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

    C 10.0.0.0/8 is directly connected, Ethernet0/0

    L 10.0.0.1/32 is directly connected, Ethernet0/0

    (Note:-above output is called routing table of the router. In this table router keeps the entries of

    networks know to him, We can see C as legend before network entry of 10.0.0.0/8 it shows that it

    is directly connected on Ethernet 0/0, L entry shows the local ip address of the network 10.0.0.0/8,

    which we assigned to the interface int this task.)

    Task 10Check the current configuration of the router with show running-config command

    and save the configuration.

    Verification:

    R1#show running-config

    Building configuration...

    Current configuration : 1161 bytes

    !

    version 12.4

    service timestamps debug datetime msec

    service timestamps log datetime msec

    no service password-encryption

    !

    hostname R1

    !

    boot-start-marker

    boot-end-marker

    !

    !

  • 5/23/2018 Ccna Lab Manual

    12/109

    no aaa new-model

    clock timezone IST 5 30

    mmi polling-interval 60

    no mmi auto-configure

    no mmi pvc

    mmi snmp-timeout 180

    ip source-route!

    !

    !

    !

    ip cef

    no ipv6 traffic interface-statistics

    no ipv6 cef

    !

    multilink bundle-name authenticated

    !

    !

    !

    redundancy

    !

    !

    !

    interface Ethernet0/0

    ip address 10.0.0.1 255.0.0.0

    !

    interface Ethernet0/1

    no ip address

    shutdown

    !

    interface Ethernet0/2

    no ip address

    shutdown

    !

    interface Ethernet0/3

    no ip address

    shutdown

    !

    interface Serial1/0

    no ip address

    shutdown

    serial restart-delay 0

    !

    interface Serial1/1

  • 5/23/2018 Ccna Lab Manual

    13/109

    no ip address

    shutdown

    serial restart-delay 0

    !

    interface Serial1/2

    no ip address

    shutdownserial restart-delay 0

    !

    interface Serial1/3

    no ip address

    shutdown

    serial restart-delay 0

    !

    ip forward-protocol nd

    !

    !

    no ip http server

    no ip http secure-server

    !

    !

    control-plane

    !

    !

    line con 0

    logging synchronous

    line aux 0

    line vty 0 4

    login

    !

    exception data-corruption buffer truncate

    end

    R1#

    R1#write

    Building configuration...

    [OK]

    R1#

    Task 11Erase All the Devices and Reload

    Solution:

    R1#write erase

    Erasing the nvram filesystem will remove all configuration files! Continue?[confirm]

  • 5/23/2018 Ccna Lab Manual

    14/109

    [OK]

    Erase of nvram: complete

    R1#

    *Jul 1 01:09:36.006: %SYS-7-NV_BLOCK_INIT: Initialized the geometry of nvram

    R1#reload

    Proceed with reload? [confirm]

    *Jul 1 01:09:39.958: %SYS-5-RELOAD: Reload requested by console. ReloadReason: Reload Command.

    R2#write erase

    Erasing the nvram filesystem will remove all configuration files! Continue?[confirm]

    [OK]

    Erase of nvram: complete

    R2#

    *Jul 1 01:09:36.006: %SYS-7-NV_BLOCK_INIT: Initialized the geometry of nvram

    R2#reload

    Proceed with reload? [confirm]

    *Jul 1 01:09:39.958: %SYS-5-RELOAD: Reload requested by console. ReloadReason: Reload Command.

    ...

  • 5/23/2018 Ccna Lab Manual

    15/109

    IP Routing

    Need of Routing:-

    Routing is the process of moving data from one network to another by forwarding packets viagateways. With IP based networks, the routing decision is based on the destination address in theIP packet's header. Routing is the process of moving a packet of data from one network to another

    network based on the destination IP address. The Internet uses routing to move data from yourcomputer, across several networks, to reach a final destination, like a website. Specializedcomputer devices that perform this routing function are referred to as routers. Routers use theinformation contained in a route to make decisions about which network interface to forward apacket through in order to reach the destination address in the packet. Routers maintain a list ofroutes which is often referred to as a routing table.

    Routers look up routes in the routing table to figure out how to move data from one network toanother network. Routes are simply the signposts that tell a router which network interface toforward a packet through in order

    toreach the packet's intended destination

    Types of Routing

    There are two basic kinds of routes: static or dynamic.

    1. Static Routes

    Routes can be entered into a router by a person who administrates the network (the networkadministrator). Since these routes are entered by the administrator, and these routes don't changeuntil the administrator changes them, they are referred to as staticroutes.

    2. Default Routes

    A default route is also referred to as the 'route of last resort'. This is the route a router uses when allother routes have been examined and none seem to be the right route to use.

    3.Dynamic Routes

    If the routes are learned on-the-fly from other routers, it is called a dynamically-learned route, or adynamic routefor short. Dynamic routes are learned from routing protocols.

    4.Routing Protocol

    A routing protocol is a standardized process by which routers learn and communicate connectivity

    information, called routes, each of which which describes how to reach a destination host and

    network. Routers that wish to exchange routing information must use the same routing protocol to

    communicate routing information.

  • 5/23/2018 Ccna Lab Manual

    16/109

    Routing is the process of learning all the paths through the network (routes) and using routes toforward data from one network to another. Aprotocolis a standardized way to perform a task. So, arouting protocol would be a standardized way of learning routes and moving data from one networkto another.

    Routing protocols are used by routers to dynamically learn all paths through a set of networks andforward data between the networks. Routers are specialized computer devices designed to performrouting.

    5.Examples of Routing Protocols

    EIGRP OSPF RIP, RIP II IS-IS BGP

  • 5/23/2018 Ccna Lab Manual

    17/109

    Static Routing Configuration

    Task 1Assign Hostnames to Router1, Router2, Router3 R1, R2, R3 respectively.

    Solution:

    On Router1 :

    Router>enable

    Router#config

    Router#configure terminal

    Router(config)#hostname R1

    R1(config)#

    On Router2 :

    Router>enable

    Router#config

    Router#configure terminal

    Router(config)#hostname R2

    R2(config)#

    On Router3 :

    Router>enable

  • 5/23/2018 Ccna Lab Manual

    18/109

    Router#config

    Router#configure terminal

    Router(config)#hostname R3

    R3(config)#

    Task 2 Assign IP address 12.0.0.1 and subnet mask of 255.0.0.0 to interface Serial 1/0 andIP address 10.0.0.1 255.0.0.0 to interface Ethernet0/0 on R1. After you complete yourconfiguration verify it.

    Solution:

    On R1 :

    R1(config)#interface serial 1/0

    R1(config-if)#ip address 12.0.0.1 255.0.0.0

    R1(config-if)#no shutdown

    R1(config-if)#exit

    R1(config-if)#int ethernet0/0

    R1(config-if)#ip address 10.0.0.1 255.0.0.0

    R1(config-if)#no shutdown

    R1(config-if)#exit

    R1(config)#exit

    Verification :

    R1#show ip interface brief

    Interface IP-Address OK? Method Status Protocol

    Ethernet0/0 10.0.0.1 YES manual up up

    Ethernet0/1 unassigned YES unset administratively down down

    Ethernet0/2 unassigned YES unset administratively down down

    Ethernet0/3 unassigned YES unset administratively down down

    Serial1/0 12.0.0.1 YES manual up up

    Serial1/1 unassigned YES unset administratively down down

    Serial1/2 unassigned YES unset administratively down down

    Serial1/3 unassigned YES unset administratively down down

    Task 3 Similarly assign ip address to R2 and R3 as per the diagram.

  • 5/23/2018 Ccna Lab Manual

    19/109

    Solution:

    On R2 :

    R2(config)#interface serial 1/0

    R2(config-if)#ip address 12.0.0.2 255.0.0.0

    R2(config-if)#clock rate 64000

    R2(config-if)#no shutdown

    R2(config-if)#exit

    R2(config)#interface serial 1/1

    R2(config-if)#ip address 23.0.0.2 255.0.0.0

    R2(config-if)#clock rate 64000

    R2(config-if)#no shutdown

    R2(config)#interface ethernet 0/0

    R2(config-if)#ip address 20.0.0.2 255.0.0.0

    R2(config-if)#no shutdown

    R2(config-if)#exit

    R2(config)#exit

    R2#

    Verification:

    R2#show ip int brief

    Interface IP-Address OK? Method Status Protocol

    Ethernet0/0 20.0.0.2 YES manual up up

    Ethernet0/1 unassigned YES unset administratively down down

    Ethernet0/2 unassigned YES unset administratively down down

    Ethernet0/3 unassigned YES unset administratively down down

    Serial1/0 12.0.0.2 YES manual up up

    Serial1/1 23.0.0.2 YES manual up up

    Serial1/2 unassigned YES unset administratively down down

    Serial1/3 unassigned YES unset administratively down down

    On R3 :

    R3(config)#interface serial 1/0

    R3(config-if)#ip address 23.0.0.3 255.0.0.0

  • 5/23/2018 Ccna Lab Manual

    20/109

    R3(config-if)#no shutdown

    R3(config-if)#exit

    R3(config)#interface ethernet 0/0

    R3(config-if)#ip address 30.0.0.3 255.0.0.0

    R3(config-if)#no shutdown

    R3(config-if)#exit

    R3(config)#exit

    R3#

    Task 4Check Connectivity Between Directly Connected Interfaces.

    Verification:

    On R1:

    R1#ping 12.0.0.2

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 12.0.0.2, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/12 ms

    On R2 :

    R2#

    R2#ping 12.0.0.1

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 12.0.0.1, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 8/9/12 ms

    R2#ping 23.0.0.3

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 23.0.0.3, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/12 ms

    R2#

    On R3 :

  • 5/23/2018 Ccna Lab Manual

    21/109

    R3#

    R3#ping 23.0.0.2

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 23.0.0.2, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/12 ms

    R3#

    Task 5 Save your configuration

    Solution:

    On R1:

    R1#write

    On R2:

    R2#write

    On R3:

    R3#write

    Task 6 Configure a static route from R1 so that it can reach networks 23.0.0.0/8, 20.0.0.0/830.0.0.0/8

    Solution:

    On R1:

    R1#

    R1#config terminal

    R1(config)#ip route 20.0.0.0 255.0.0.0 12.0.0.2

    R1(config)#ip route 23.0.0.0 255.0.0.0 12.0.0.2

    R1(config)#ip route 30.0.0.0 255.0.0.0 12.0.0.2

    Verification:

    R1#

    R1#show ip route

    Codes: L local, C connected, S static, R RIP, M mobile,

    B BGP, D EIGRP, EX EIGRP external, O OSPF,

    IA OSPF inter area, N1 OSPF NSSA external type 1,

    N2 OSPF NSSA external type 2 E1 OSPF external type 1,

  • 5/23/2018 Ccna Lab Manual

    22/109

    E2 OSPF external type 2, i IS-IS, su IS-IS summary,

    L1 IS-IS level-1, L2 IS-IS level-2, ia IS-IS inter area

    * - candidate default, U per-user static route o ODR,

    P periodic downloaded static route, + - replicated route

    Gateway of last resort is not set

    10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

    C 10.0.0.0/8 is directly connected, Ethernet0/0

    L 10.0.0.1/32 is directly connected, Ethernet0/0

    12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

    C 12.0.0.0/8 is directly connected, Serial1/0

    L 12.0.0.1/32 is directly connected, Serial1/0

    S 20.0.0.0/8 [1/0] via 12.0.0.2

    S 23.0.0.0/8 [1/0] via 12.0.0.2

    S 30.0.0.0/8 [1/0] via 12.0.0.2

    R1#

    Task 7 Configure R2 so that it gets reach ability to networks 10.0.0.0/8, and 30.0.0.0/8 do not specify

    next hop address to achieve this task

    On R2 :

    R2#

    R2#configure terminal

    R2(config)#ip route 10.0.0.0 255.0.0.0 serial 1/0

    R2(config)#ip route 30.0.0.0 255.0.0.0 serial 1/1

    R2(config)#exit

    R2#

    Verification:

    R2#

    R2#show ip route

    Codes: L local, C connected, S static, R RIP, M mobile,

    B BGP, D EIGRP, EX EIGRP external, O OSPF,

    IA OSPF inter area, N1 OSPF NSSA external type 1,

    N2OSPF NSSA external type 2, E1

    OSPF external type 1,

    E2 OSPF external type 2, i IS-IS, su IS-IS summary,

    L1 IS-IS level-1, L2 IS-IS level-2, ia IS-IS inter area,

  • 5/23/2018 Ccna Lab Manual

    23/109

    * - candidate default, U per-user static route

    o ODR, P periodic downloaded static route, + - replicated

    route

    Gateway of last resort is not set

    S 10.0.0.0/8 is directly connected, Serial1/0

    12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

    C 12.0.0.0/8 is directly connected, Serial1/0

    L 12.0.0.2/32 is directly connected, Serial1/0

    20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

    C 20.0.0.0/8 is directly connected, Ethernet0/0

    L 20.0.0.2/32 is directly connected, Ethernet0/0

    23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

    C 23.0.0.0/8 is directly connected, Serial1/1

    L 23.0.0.2/32 is directly connected, Serial1/1

    S 30.0.0.0/8 is directly connected, Serial1/1

    R2#

    Task 8: Configure R3 in such a manner that it gets rechability to all other networks in single static

    route. Do not configure any more specific static routes to achieve this task.

    On R3 :

    R3#

    R3#configure terminal

    R3(config)#ip route 0.0.0.0 0.0.0.0 23.0.0.2

    R3(config)#exit

    R3#

    Verification :

    R3#

    R3#show ip route

    Codes: L local, C connected, S static, R RIP, M mobile,

  • 5/23/2018 Ccna Lab Manual

    24/109

    B BGP, D EIGRP, EX EIGRP external, O OSPF,

    IA OSPF inter area N1 OSPF NSSA external type 1,

    N2 OSPF NSSA external type 2 E1 OSPF external type 1,

    E2 OSPF external type 2 i IS-IS, su IS-IS summary,

    L1 IS-IS level-1, L2 IS-IS level-2

    ia IS-IS inter area, * - candidate default,

    U per-user static route

    o ODR, P periodic downloaded static route, + - replicated route

    Gateway of last resort is 23.0.0.2 to network 0.0.0.0

    S* 0.0.0.0/0 [1/0] via 23.0.0.2

    23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

    C 23.0.0.0/8 is directly connected, Serial1/0

    L 23.0.0.3/32 is directly connected, Serial1/0

    R3#

    Task 9 : Ping 30.0.0.3 from R1,

    Ping 10.0.0.1 and 30.0.0.3 for R2

    Ping 10.0.0.1 from R3 to test end to end reachability.

    R1#

    R1#ping 30.0.0.3

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 30.0.0.3, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 16/18/24ms

    R1#

    R2#

    R2#ping 10.0.0.1

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/8 ms

    R2#

    R2#ping 30.0.0.3

    Type escape sequence to abort.

  • 5/23/2018 Ccna Lab Manual

    25/109

    Sending 5, 100-byte ICMP Echos to 30.0.0.3, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 8/37/80 ms

    R2#

    R3#

    R3#ping 10.0.0.1

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/20 ms

    R3#

    Explanation:-

    As we see from above output that we have got the full reachabltiy.

    On R1 we have give destination network i.e 20.0.0.0,23.0.0.0 and 30.0.0.0 and their respectivesubnet masks and in the last part we gave the next hop address that is router to whom packetshould be routed.

    Here the ip route format is ip route

    ip route 20.0.0.0 255.0.0.0 12.0.0.2

    ip route 23.0.0.0 255.0.0.0 12.0.0.2

    ip route 30.0.0.0 255.0.0.0 12.0.0.2

    on R2 we have been instructed not to give next hop address so we can here give outgoing interface

    ip route 10.0.0.0 255.0.0.0 serial1/0

    ip route 30.0.0.0 255.0.0.0 serial1/1

    On R3 we have instructed not to use any specific routes so here we are using special static routewhich is also called as default route. That is if router does not get any specific network in his routingtable. It is going to use the default route to route the packet.

  • 5/23/2018 Ccna Lab Manual

    26/109

    ip route 0.0.0.0 0.0.0.0 23.0.0.2

    RIPv2

    RIPv2 was first described in RFC 1388 and RFC 1723 (1994); the current RFC is 2453, written inNovember 1998. Although current environments use advanced routing protocols such as OSPF andEIGRP, there still are networks using RIP. The need to use VLSMs and other requirementsprompted the definition of RIPv2.

    RIPv2 improves upon RIPv1 with the ability to use VLSM, with support for route authentication, andwith multicasting of route updates. RIPv2 supports CIDR. It still sends updates every 30 secondsand retains the 15-hop limit; it also uses triggered updates. RIPv2 still uses UDP port 520; the RIPprocess is responsible for checking the version number. It retains the loop-prevention strategies ofpoison reverse and counting to infinity. On Cisco routers, RIPv2 has the same administrativedistance as RIPv1, which is 120. Finally, RIPv2 uses the IP address 224.0.0.9 when multicastingroute updates to other RIP routers. As in RIPv1, RIPv2 will, by default, summarize IP networks atnetwork boundaries. You can disable auto-summarization if required.

    You can use RIPv2 in small networks where VLSM is required. It also works at the edge of largernetworks.

    RIPv2 Forwarding Information Base

    RIPv2 maintains a routing table database as in Version 1. The difference is that it also keeps thesubnet mask information. The following list repeats the table information of RIPv1:

  • 5/23/2018 Ccna Lab Manual

    27/109

    IP addressIP address of the destination host or network, with subnet mask GatewayThe first gateway along the path to the destination InterfaceThe physical network that must be used to reach the destination MetricA number indicating the number of hops to the destination TimerThe amount of time since the route entry was last updated

    RIPv2 Design

    Things to remember in designing a network with RIPv2 include that it supports VLSM withinnetworks and CIDR for network summarization across adjacent networks. RIPv2 allows for thesummarization of routes in a hierarchical network. RIPv2 is still limited to 16 hops; therefore, thenetwork diameter cannot exceed this limit. RIPv2 multicasts its routing table every 30 secondsto the multicast IP address 224.0.0.9. RIPv2 is usually limited to accessing networks where it caninteroperate with servers running routedor with non-Cisco routers. RIPv2 also appears at the edgeof larger internetworks. RIPv2 further provides for route authentication.

    Split Horizon:

    In this example, network node A routes packets to node B in order to reach node C. The linksbetween the nodes are distinct point-to-point links.

    According to the split-horizon rule, nodeAdoes not advertise its route for C (namelyA to B to C)back to B. On the surface, this seems redundant since Bwill never route via node Abecause theroute costs more than the direct route from Bto C. However, if the link between Band Cgoes down,and Bhad received a route fromA, Bcould end up using that route via A.Awould send the packetright back to B, creating a loop. With the split-horizon rule in place, this particular loop scenariocannot happen, improving convergence time in complex, highly-redundant environments

    Poison Reverse:

    Split-horizon routing with poison reverse is a variant of split-horizon route advertising in which arouter actively advertises routes as unreachable over the interface over which they were learned.The effect of such an announcement is to immediately remove most looping routes before they canpropagate through the network.

    The main disadvantage of poison reverse is that it can significantly increase the size of routingannouncements in certain fairly common network topologies.

    RIPv2 Summary

    The characteristics of RIPv2 follow:

    Distance-vector protocol. Uses UDP port 520. Classless protocol (support for CIDR).

    http://en.wikipedia.org/wiki/File:A-B-C.svg
  • 5/23/2018 Ccna Lab Manual

    28/109

    Supports VLSMs. Metric is router hop count. Maximum hop count is 15; infinite (unreachable) routes have a metric of 16. Periodic route updates sent every 30 seconds to multicast address 224.0.0.9. 25 routes per RIP message (24 if you use authentication). Supports authentication. Implements split horizon with poison reverse. Implements triggered updates.

    Subnet mask included in route entry. Administrative distance for RIPv2 is 120. Used in small, flat networks or at the edge of larger networks.

    RIP Configuration

    Load IP Routing initials prior to starting

    Task 1 Configure RIPv2 on R1 advertise its all network into RIP

    Solution:

    On R1:

    R1#

    R1#configure terminal

    R1(config)#router rip

    R1(config-router)#version 2

    R1(config-router)#network 10.0.0.0

  • 5/23/2018 Ccna Lab Manual

    29/109

    R1(config-router)#network 12.0.0.0

    R1(config-router)#exit

    R1(config)#exit

    R1#

    Verification:

    On R1:

    R1#

    R1#show ip protocols

    *** IP Routing is NSF aware ***

    Routing Protocol is "rip"

    Outgoing update filter list for all interfaces is not set

    Incoming update filter list for all interfaces is not set

    Sending updates every 30 seconds, next due in 27 secondsInvalid after 180 seconds, hold down 180, flushed after 240

    Redistributing: rip

    Default version control: send version 2, receive version 2

    Interface Send Recv Triggered RIP Key-chain

    Ethernet0/0 2 2

    Serial1/0 2 2

    Automatic network summarization is in effect

    Maximum path: 4

    Routing for Networks:

    10.0.0.0

    12.0.0.0

    Routing Information Sources:

    Gateway Distance Last Update

    Distance: (default is 120)

    R1#

    Task 2 From above output we can see that R1 is doing auto-summarization so disable auto-summarization on R1

  • 5/23/2018 Ccna Lab Manual

    30/109

    Solution:

    On R1:

    R1#

    R1#configure terminal

    R1(config)#router rip

    R1(config-router)#no auto-summary

    R1(config-router)#exit

    R1(config)#exit

    R1#

    Verification:

    R1#

    R1#show ip protocols

    *** IP Routing is NSF aware ***

    Routing Protocol is "rip"

    Outgoing update filter list for all interfaces is not set

    Incoming update filter list for all interfaces is not set

    Sending updates every 30 seconds, next due in 0 secondsInvalid after 180 seconds, hold down 180, flushed after 240

    Redistributing: rip

    Default version control: send version 2, receive version 2

    Interface Send Recv Triggered RIP Key-chain

    Ethernet0/0 2 2

    Serial1/0 2 2

    Automatic network summarization is not in effect

    Maximum path: 4

    Routing for Networks:

    10.0.0.0

    12.0.0.0

    Routing Information Sources:

    Gateway Distance Last Update

    Distance: (default is 120)

    R1#

    Task 3configure RIP v2 on R2 and R3 advertise all the networks and disable auto-

    summarization.

  • 5/23/2018 Ccna Lab Manual

    31/109

    Solution:

    On R2:

    R2#

    R2#config terminal

    R2(config)#router rip

    R2(config-router)#version 2

    R2(config-router)#no auto-summary

    R2(config-router)#network 12.0.0.0

    R2(config-router)#network 23.0.0.0

    R2(config-router)#network 20.0.0.0

    R2(config-router)#exit

    R2(config)#exit

    R2#

    On R3:

    R3#

    R3#configure terminal

    R3(config)#router rip

    R3(config-router)#no auto-summary

    R3(config-router)#version 2

    R3(config-router)#network 23.0.0.0

    R3(config-router)#network 30.0.0.0

    R3(config-router)#exit

    R3(config)#exit

    R3#

    Task 4 Verify Routing tables of all 3 routers and test end-to-end connectivity.

    Verification:

    R1#show ip route

    Codes: L - local, C - connected, S - static, R - RIP, M - mobile,

    B BGP D - EIGRP, EX - EIGRP external, O - OSPF,

    IA - OSPF inter area N1 - OSPF NSSA external type 1,

  • 5/23/2018 Ccna Lab Manual

    32/109

    N2 - OSPF NSSA external type 2, E1 - OSPF external type 1,

    E2 - OSPF external type 2 i - IS-IS, su - IS-IS summary,

    L1 - IS-IS level-1, L2 - IS-IS level-2 ia - IS-IS inter area,

    * - candidate default, U - per-user static route

    o - ODR, P - periodic downloaded static route,

    + - replicated route

    Gateway of last resort is not set

    10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

    C 10.0.0.0/24 is directly connected, Ethernet0/0

    L 10.0.0.1/32 is directly connected, Ethernet0/0

    12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

    C 12.0.0.0/24 is directly connected, Serial1/0

    L 12.0.0.1/32 is directly connected, Serial1/0

    20.0.0.0/24 is subnetted, 1 subnets

    R 20.0.0.0 [120/1] via 12.0.0.2, 00:00:24, Serial1/0

    23.0.0.0/24 is subnetted, 1 subnets

    R 23.0.0.0 [120/1] via 12.0.0.2, 00:00:24, Serial1/0

    30.0.0.0/24 is subnetted, 1 subnets

    R 30.0.0.0 [120/2] via 12.0.0.2, 00:00:24, Serial1/0

    R1#

    R1#ping 23.0.0.2

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 23.0.0.2, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 8/10/16 ms

    R1#ping 20.0.0.2

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 20.0.0.2, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/8 ms

    R1#ping 30.0.0.3

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 30.0.0.3, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 12/16/20 ms

  • 5/23/2018 Ccna Lab Manual

    33/109

    R1#

    On R2:

    R2#

    R2#show ip route

    Codes: L - local, C - connected, S - static, R - RIP, M - mobile,

    B - BGP, D - EIGRP, EX - EIGRP external, O - OSPF,

    IA - OSPF inter area , N1 - OSPF NSSA external type 1,

    N2 - OSPF NSSA external type 2

    E1 - OSPF external type 1, E2 - OSPF external type 2

    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1,

    L2 - IS-IS level-2 , ia - IS-IS inter area,

    * - candidate default, U - per-user static route

    o - ODR, P - periodic downloaded static route,+ - replicated route

    Gateway of last resort is not set

    10.0.0.0/24 is subnetted, 1 subnets

    R 10.0.0.0 [120/1] via 12.0.0.1, 00:00:14, Serial1/0

    12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

    C 12.0.0.0/24 is directly connected, Serial1/0

    L 12.0.0.2/32 is directly connected, Serial1/0

    20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

    C 20.0.0.0/24 is directly connected, Ethernet0/0

    L 20.0.0.2/32 is directly connected, Ethernet0/0

    23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

    C 23.0.0.0/24 is directly connected, Serial1/1

    L 23.0.0.2/32 is directly connected, Serial1/1

    30.0.0.0/24 is subnetted, 1 subnets

    R 30.0.0.0 [120/1] via 23.0.0.3, 00:00:27, Serial1/1

    R2#

    R2#

    R2#ping 10.0.0.1

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/12 ms

    R2#ping 30.0.0.3

  • 5/23/2018 Ccna Lab Manual

    34/109

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 30.0.0.3, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/12 ms

    R2#

    On R3:

    R3#

    R3#show ip route

    Codes: L - local, C - connected, S - static, R - RIP, M - mobile,

    B BGP, D - EIGRP, EX - EIGRP external, O - OSPF,

    IA - OSPF inter area, N1 - OSPF NSSA external type 1,

    N2 - OSPF NSSA external type 2, E1 - OSPF external type 1,

    E2 - OSPF external type 2, i - IS-IS, su - IS-IS summary,

    L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

    , * - candidate default, U - per-user static route

    o - ODR, P - periodic downloaded static route, + - replicated route

    Gateway of last resort is not set

    10.0.0.0/24 is subnetted, 1 subnets

    R 10.0.0.0 [120/2] via 23.0.0.2, 00:00:06, Serial1/0

    12.0.0.0/24 is subnetted, 1 subnets

    R 12.0.0.0 [120/1] via 23.0.0.2, 00:00:06, Serial1/0

    20.0.0.0/24 is subnetted, 1 subnets

    R 20.0.0.0 [120/1] via 23.0.0.2, 00:00:06, Serial1/0

    23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

    C 23.0.0.0/24 is directly connected, Serial1/0

    L 23.0.0.3/32 is directly connected, Serial1/0

    30.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

    C 30.0.0.0/24 is directly connected, Ethernet0/0

    L 30.0.0.3/32 is directly connected, Ethernet0/0

    R3#

    R3#

    R3#ping 12.0.0.1

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 12.0.0.1, timeout is 2 seconds:

    !!!!!

  • 5/23/2018 Ccna Lab Manual

    35/109

    Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/20 ms

    R3#ping 20.0.0.2

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 20.0.0.2, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 4/8/12 ms

    R3#ping 10.0.0.1

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/20 ms

    R3#

    Task 5Configure all three routers in such way that they send updates through only required

    interfaces

    Solution:

    On R1:

    R1#config terminal

    R1(config)#router rip

    R1(config-router)#passive-interface ethernet 0/0

    R1(config-router)#exit

    R1(config)#exit

    R1#

    On R2:

    R2#config terminal

    R2(config)#router rip

    R2(config-router)#passive-interface ethernet 0/0

    R2(config-router)#exit

    R2(config)#exit

    R2#

    On R3:

  • 5/23/2018 Ccna Lab Manual

    36/109

    R3#config terminal

    R3(config)#router rip

    R3(config-router)#passive-interface ethernet 0/0

    R3(config-router)#exit

    R3(config)#exit

    R3

    Verification:

    R1#

    R1#show ip protocols

    *** IP Routing is NSF aware ***

    Routing Protocol is "rip"

    Outgoing update filter list for all interfaces is not set

    Incoming update filter list for all interfaces is not set

    Sending updates every 30 seconds, next due in 2 seconds

    Invalid after 180 seconds, hold down 180, flushed after 240

    Redistributing: rip

    Default version control: send version 2, receive version 2

    Interface Send Recv Triggered RIP Key-chain

    Serial1/0 2 2Automatic network summarization is not in effect

    Maximum path: 4

    Routing for Networks:

    10.0.0.0

    12.0.0.0

    Passive Interface(s):

    Ethernet0/0

    Routing Information Sources:

    Gateway Distance Last Update

    12.0.0.2 120 00:00:01

    Distance: (default is 120)

    Explanation:

    Task 1 is asking us to configure RIP version 2 on all the interfaces. In the router rip sub

    configuration we have to advertise our interfaces with network command. We can only declare

    networks in their classfull boundaries. Version 2 is to be specified as default behavior is send

    version 1 updates and receive both version 1 and version 2 updates.

    This configuration can be checked in show ip protocols

  • 5/23/2018 Ccna Lab Manual

    37/109

    In configuration of task 2 we can see that by default RIP will always do auto-summarization. To

    disable the auto-summarization we can give no auto-summary under RIP routing process.

    Task 5 is asking us to send RIPv2 updates only out of required interface. Always remember that

    RIPv2 does support classless network advertisement but we can only publish classfull networks in

    RIPv2. By default all the routing protocols except BGP, Send hello packets and advertise the

    networks, which we have defined by network command. In RIPv2 if we make a passive interface

    then that interface is advertised but it does not send any updates. But the limitation in RIPv2 is this

    interface can still receive RIP updates.

    EIGRPImplementing EIGRP

    EIGRP is an advanced distance vector routing protocol developed by Cisco. EIGRP is suited formany different topologies and media. In a well-designed network, EIGRP scales well and providesextremely quick convergence times with minimal overhead. EIGRP is a popular choice for a routingprotocol on Cisco devices.

    Introducing EIGRP

    EIGRP is a Cisco-proprietary routing protocol that combines the advantages of link-state anddistance vector routing protocols. EIGRP is an advanced distance vector or hybrid routing protocolthat includes the following features:

    Rapid Convergence

  • 5/23/2018 Ccna Lab Manual

    38/109

    EIGRP uses the Diffusing Update Algorithm (DUAL) to achieve rapid convergence. A router thatuses EIGRP stores all available backup routes for destinations so that it can quickly adapt toalternate routes. If no appropriate route or backup route exists in the local routing table, EIGRPqueries its neighbors to discover an alternate route.

    Reduced bandwidth usage

    EIGRP does not make periodic updates. Instead, it sends partial updates when the path or the

    metric changes for that route. When path information changes, DUAL sends an update about onlythat link rather than about the entire table.

    Multiple network layer support

    EIGRP supports AppleTalk, IP version 4 (IPv4), IP version 6 (IPv6), and Novell Internetwork PacketExchange (IPX), which use protocol-dependent modules (PDM). PDMs are responsible for protocolrequirements that are specific to the network layer.

    Classless routing

    Because EIGRP is a classless routing protocol, it advertises a routing mask for each destinationnetwork. The routing mask feature enables EIGRP to support discontiguous subnetworks andvariable-length subnet masks (VLSM).

    Less overhead

    EIGRP uses multicast and unicast rather than broadcast. As a result, end stations are unaffectedby routing updates and requests for topology information.

    Load balancing

    EIGRP supports unequal metric load balancing, which allows administrators to better distribute

    traffic flow in their networks.

    Easy summarization

    EIGRP enables administrators to create summary routes anywhere within the network rather thanrely on the traditional distance vector approach of performing classful route summarization only atmajor network boundaries.

    Each EIGRP router maintains a neighbor table. This table includes a list of directly connectedEIGRP routers that have an adjacency with this router.

    Each EIGRP router maintains a topology table for each routed protocol configuration. The topologytable includes route entries for every destination that the router learns. EIGRP chooses the bestroutes to a destination from the topology table and places these routes in the routing table.

    In EIGRP, the best route is called a successor route while a backup route is called the feasiblesuccessor. To determine the best route (successor) and the backup route (feasible successor) to adestination, EIGRP uses the following two parameters:

    Advertised distance

    The EIGRP metric for an EIGRP neighbor to reach a particular network

  • 5/23/2018 Ccna Lab Manual

    39/109

    Feasible distance

    The advertised distance for a particular network learned from an EIGRP neighbor plus the EIGRPmetric to reach that neighbor

    A router compares all feasible distances to reach a specific network and then selects the lowestfeasible distance and places it in the routing table. The feasible distance for the chosen routebecomes the EIGRP routing metric to reach that network in the routing table.

    The EIGRP topology database contains all the routes that are known to each EIGRP neighbor.Routers A and B send their routing tables to Router C, whose table is displayed in Both Routers Aand B have pathways to network 10.1.1.0/24, as well as to other networks that are not shown

    .

    Configuring and Verifying EIGRP

    Use the router eigrp and network commands to create an EIGRP routing process. Note thatEIGRP requires an autonomous system (AS) number. The AS number does not have to beregistered as is the case when routing on the Internet with the Border Gateway Protocol (BGP)routing protocol. However, all routers within an AS must use the same AS number to exchangerouting information with each other.

    The networkcommand defines a major network number to which the router is directly connected.The EIGRP routing process looks for interfaces that have an IP address that belongs to thenetworks that are specified with the networkcommand and begins the EIGRP process on theseinterfaces.

  • 5/23/2018 Ccna Lab Manual

    40/109

    EIGRP Command Example

    Command Description

    router eigrp 100 Enables the EIGRP routing process for AS 100

    network 172.16.0.0 Associates network 172.16.0.0 with the EIGRP routing process

    network 10.0.0.0 Associates network 10.0.0.0 with the EIGRP routing process

    EIGRP sends updates out of the interfaces in networks 10.0.0.0 and 172.16.0.0. The updatesinclude information about networks 10.0.0.0 and 172.16.0.0 and any other networks that EIGRPlearns.

    EIGRP automatically summarizes routes at the classful boundary. In some cases, you might notwant automatic summarization to occur. For example, if you have discontiguous networks, you needto disable automatic summarization to minimize router confusion.

    To disable automatic summarization, use the no auto-summary command in the EIGRP routerconfiguration mode.

    The show ip protocolscommand displays the parameters and current state of the active routingprotocol process. This command shows the EIGRP AS number. It also displays filtering andredistribution numbers and neighbor and distance information. This also shows the networks thatare currently being advertised on the router by the protocol.

    Use the show ip eigrp interfaces [type number] [as-number] command to determine on whichinterfaces EIGRP is active, and to learn information about EIGRP that relates to those interfaces. Ifyou specify an interface by using the type numberoption, only that interface is displayed. Otherwise,all interfaces on which EIGRP is running are displayed. If you specify an AS using the as-numberoption, only the routing process for the specified AS is displayed. Otherwise, all EIGRP processesare displayed. Exam shows the output of the show ip eigrp interfacescommand.

    EIGRP Summary

    The characteristics of EIGRP follow:

    Hybrid routing protocol (distance vector that has link-state protocol characteristics). Uses IP protocol 88. Classless protocol (supports VLSMs). Default composite metric uses bandwidth and delay. You can factor load and reliability into the metric. Sends partial route updates only when there are changes. Support for authentication.

    Uses DUAL for loop prevention. By default, equal-cost load balancing. Unequal-cost load balancing with the variancecommand. Administrative distance is 90 for EIGRP internal routes, 170 for EIGRP external routes, and 5 for

    EIGRP summary routes. Potential routing protocol for the core of a network; used in large networks.

  • 5/23/2018 Ccna Lab Manual

    41/109

    EIGRP Configuration

    Load IP Routing Initials Prior to Starting

    Task 1Configure EIGRP AS 100 on R1 advertise its all networks into EIGRP

    Solution:

    On R1 :

    R1#

    R1#configure terminal

  • 5/23/2018 Ccna Lab Manual

    42/109

    R1(config)#router eigrp 100

    R1(config-router)#network 10.0.0.0

    R1(config-router)#network 12.0.0.0

    R1(config-router)#exit

    R1(config)#exit

    R1#

    Verification:

    On R1:

    R1#

    *** IP Routing is NSF aware ***

    Routing Protocol is "eigrp 100"

    Outgoing update filter list for all interfaces is not set

    Incoming update filter list for all interfaces is not set

    Default networks flagged in outgoing updates

    Default networks accepted from incoming updates

    Redistributing: eigrp 100

    EIGRP-IPv4 Protocol for AS(100)

    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0

    NSF-aware route hold timer is 240

    Router-ID: 12.0.0.1

    Topology : 0 (base)

    Active Timer: 3 min

    Distance: internal 90 external 170

    Maximum path: 4

    Maximum hopcount 100

    Maximum metric variance 1

    Automatic Summarization: enabled

    Maximum path: 4

    Routing for Networks:

    10.0.0.0

    12.0.0.0

  • 5/23/2018 Ccna Lab Manual

    43/109

    Routing Information Sources:

    Gateway Distance Last Update

    Distance: internal 90 external 170

    R1#

    Task 2 From above output we can see that R1 is doing auto-summarization so disable auto-summarization on R1

    Solution:

    On R1:

    R1#

    R1#configure terminal

    R1(config)#router eigrp 100

    R1(config-router)#no auto-summary

    R1(config-router)#exit

    R1(config)#exit

    R1#

    Verification:

    R1#

    R1#show ip protocols

    *** IP Routing is NSF aware ***

    Routing Protocol is "eigrp 100"

    Outgoing update filter list for all interfaces is not set

    Incoming update filter list for all interfaces is not set

    Default networks flagged in outgoing updates

    Default networks accepted from incoming updates

    Redistributing: eigrp 100

    EIGRP-IPv4 Protocol for AS(100)

    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0

    NSF-aware route hold timer is 240

    Router-ID: 12.0.0.1

    Topology : 0 (base)

  • 5/23/2018 Ccna Lab Manual

    44/109

    Active Timer: 3 min

    Distance: internal 90 external 170

    Maximum path: 4

    Maximum hopcount 100

    Maximum metric variance 1

    Automatic Summarization: disabled

    Maximum path: 4

    Routing for Networks:

    10.0.0.0

    12.0.0.0

    Routing Information Sources:

    Gateway Distance Last Update

    Distance: internal 90 external 170

    R1#

    Task 4 configure EIGRP AS 100 on R2 and R3 advertise all the networks and disable auto-

    summarization.

    Solution:

    On R2:

    R2#

    R2#config terminal

    R2(config)#router eigrp 100

    R2(config-router)#no auto-summary

    R2(config-router)#network 12.0.0.0

    R2(config-router)#network 23.0.0.0

    R2(config-router)#network 20.0.0.0

    R2(config-router)#exit

    R2(config)#exit

    R2#

    On R3:

    R3#

    R3#configure terminal

  • 5/23/2018 Ccna Lab Manual

    45/109

    R3(config)#router eigrp 100

    R3(config-router)#no auto-summary

    R3(config-router)#network 23.0.0.0

    R3(config-router)#network 30.0.0.0

    R3(config-router)#exit

    R3(config)#exit

    R3#

    Task 5Verify Routing tables of all 3 routers and test end-to-end connectivity.

    Verification:

    On R1:

    R1#show ip route

    Codes: L - local, C - connected, S - static, R - RIP, M - mobile,

    B BGP D - EIGRP, EX - EIGRP external, O - OSPF,

    IA - OSPF inter area N1 - OSPF NSSA external type 1,

    N2 - OSPF NSSA external type 2, E1 - OSPF external type 1,

    E2 - OSPF external type 2 i - IS-IS, su - IS-IS summary,

    L1 - IS-IS level-1, L2 - IS-IS level-2 ia - IS-IS inter area,

    * - candidate default, U - per-user static route

    o - ODR, P - periodic downloaded static route,

    + - replicated route

    Gateway of last resort is not set

    10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

    D 10.0.0.0/24 is directly connected, Ethernet0/0

    L 10.0.0.1/32 is directly connected, Ethernet0/0

    12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

    C 12.0.0.0/24 is directly connected, Serial1/0

    L 12.0.0.1/32 is directly connected, Serial1/0

    20.0.0.0/24 is subnetted, 1 subnets

    D 20.0.0.0 [120/1] via 12.0.0.2, 00:00:24, Serial1/0

    23.0.0.0/24 is subnetted, 1 subnets

    D 23.0.0.0 [120/1] via 12.0.0.2, 00:00:24, Serial1/0

    30.0.0.0/24 is subnetted, 1 subnets

    D 30.0.0.0 [120/2] via 12.0.0.2, 00:00:24, Serial1/0

    R1#

  • 5/23/2018 Ccna Lab Manual

    46/109

    R1#

    R1#ping 23.0.0.2

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 23.0.0.2, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 8/10/16 ms

    R1#ping 20.0.0.2

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 20.0.0.2, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/8 ms

    R1#ping 30.0.0.3

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 30.0.0.3, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 12/16/20 ms

    R1#

    On R2:

    R2#

    R2#show ip route

    Codes: L - local, C - connected, S - static, R - RIP, M - mobile,

    B - BGP, D - EIGRP, EX - EIGRP external, O - OSPF,

    IA - OSPF inter area , N1 - OSPF NSSA external type 1,

    N2 - OSPF NSSA external type 2

    E1 - OSPF external type 1, E2 - OSPF external type 2

    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1,

    L2 - IS-IS level-2 , ia - IS-IS inter area,

    * - candidate default, U - per-user static route

    o - ODR, P - periodic downloaded static route,

    + - replicated route

    Gateway of last resort is not set

    10.0.0.0/24 is subnetted, 1 subnets

    D 10.0.0.0 [120/1] via 12.0.0.1, 00:00:14, Serial1/0

  • 5/23/2018 Ccna Lab Manual

    47/109

    12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

    C 12.0.0.0/24 is directly connected, Serial1/0

    L 12.0.0.2/32 is directly connected, Serial1/0

    20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

    C 20.0.0.0/24 is directly connected, Ethernet0/0

    L 20.0.0.2/32 is directly connected, Ethernet0/0

    23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

    C 23.0.0.0/24 is directly connected, Serial1/1

    L 23.0.0.2/32 is directly connected, Serial1/1

    30.0.0.0/24 is subnetted, 1 subnets

    D 30.0.0.0 [120/1] via 23.0.0.3, 00:00:27, Serial1/1

    R2#

    R2#

    R2#ping 10.0.0.1

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/12 ms

    R2#ping 30.0.0.3

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 30.0.0.3, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/12 ms

    R2#

    On R3:

    R3#

    R3#show ip route

    Codes: L - local, C - connected, S - static, R - RIP, M - mobile,

    B BGP, D - EIGRP, EX - EIGRP external, O - OSPF,

    IA - OSPF inter area, N1 - OSPF NSSA external type 1,

    N2 - OSPF NSSA external type 2, E1 - OSPF external type 1,

    E2 - OSPF external type 2, i - IS-IS, su - IS-IS summary,

    L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

    , * - candidate default, U - per-user static route

    o - ODR, P - periodic downloaded static route, + - replicated route

    Gateway of last resort is not set

  • 5/23/2018 Ccna Lab Manual

    48/109

    10.0.0.0/24 is subnetted, 1 subnets

    D 10.0.0.0 [120/2] via 23.0.0.2, 00:00:06, Serial1/0

    12.0.0.0/24 is subnetted, 1 subnets

    D 12.0.0.0 [120/1] via 23.0.0.2, 00:00:06, Serial1/0

    20.0.0.0/24 is subnetted, 1 subnets

    D 20.0.0.0 [120/1] via 23.0.0.2, 00:00:06, Serial1/0

    23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

    C 23.0.0.0/24 is directly connected, Serial1/0

    L 23.0.0.3/32 is directly connected, Serial1/0

    30.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

    C 30.0.0.0/24 is directly connected, Ethernet0/0

    L 30.0.0.3/32 is directly connected, Ethernet0/0

    R3#

    R3#

    R3#ping 12.0.0.1

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 12.0.0.1, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/20 ms

    R3#ping 20.0.0.2

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 20.0.0.2, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 4/8/12 ms

    R3#ping 10.0.0.1

    Type escape sequence to abort.Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/20 ms

    R3#

    Task 5 Configure all three routers in such manner that they send updates through only

    required interfaces

    Solution:

    On R1

  • 5/23/2018 Ccna Lab Manual

    49/109

    R1#config terminal

    R1(config)#router eigrp 100

    R1(config-router)#passive-interface ethernet 0/0

    R1(config-router)#exit

    R1(config)#exit

    R1#

    On R2:

    R2#config terminal

    R2(config)#router eigrp 100

    R2(config-router)#passive-interface ethernet 0/0

    R2(config-router)#exit

    R2(config)#exit

    R2#

    On R3:

    R3#config terminal

    R3(config)#router eigrp 100

    R3(config-router)#passive-interface ethernet 0/0

    R3(config-router)#exit

    R3(config)#exit

    R3#

    Verification:

    On R1:

    R1#

    R1#show ip protocols

    R1#show ip protocols

    *** IP Routing is NSF aware ***

  • 5/23/2018 Ccna Lab Manual

    50/109

    Routing Protocol is "eigrp 100"

    Outgoing update filter list for all interfaces is not set

    Incoming update filter list for all interfaces is not set

    Default networks flagged in outgoing updates

    Default networks accepted from incoming updates

    Redistributing: eigrp 100

    EIGRP-IPv4 Protocol for AS(100)

    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0

    NSF-aware route hold timer is 240

    Router-ID: 12.0.0.1

    Topology : 0 (base)

    Active Timer: 3 min

    Distance: internal 90 external 170

    Maximum path: 4

    Maximum hopcount 100

    Maximum metric variance 1

    Automatic Summarization: disabled

    Maximum path: 4

    Routing for Networks:

    10.0.0.0

    12.0.0.0

    Passive Interface(s):

    Ethernet0/0

    Routing Information Sources:

    Gateway Distance Last Update

    Distance: internal 90 external 170

    R1#

    OSPF

    Background Information

    OSPF protocol was developed due to a need in the internet community to introduce a highfunctionality non-proprietary Internal Gateway Protocol (IGP) for the TCP/IP protocol family. Thediscussion of the creation of a common interoperable IGP for the Internet started in 1988 and did

    not get formalized until 1991. At that time the OSPF Working Group requested that OSPF beconsidered for advancement to Draft Internet Standard.

    The OSPF protocol is based on link-state technology, which is a departure from the Bellman-Fordvector based algorithms used in traditional Internet routing protocols such as RIP. OSPF has

  • 5/23/2018 Ccna Lab Manual

    51/109

    introduced new concepts such as authentication of routing updates, Variable Length Subnet Masks(VLSM), route summarization, and so forth.

    These chapters discuss the OSPF terminology, algorithm and the pros and cons of the protocol indesigning the large and complicated networks of today.

    OSPF versus RIP

    The rapid growth and expansion of today's networks has pushed RIP to its limits. RIP has certainlimitations that can cause problems in large networks:

    RIP has a limit of 15 hops. A RIP network that spans more than 15 hops (15 routers) is consideredunreachable.

    RIP cannot handle Variable Length Subnet Masks (VLSM). Given the shortage of IP addresses andthe flexibility VLSM gives in the efficient assignment of IP addresses, this is considered a majorflaw.

    Periodic broadcasts of the full routing table consume a large amount of bandwidth. This is a majorproblem with large networks especially on slow links and WAN clouds.

    RIP converges slower than OSPF. In large networks convergence gets to be in the order of minutes.RIP routers go through a period of a hold-down and garbage collection and slowly time-outinformation that has not been received recently. This is inappropriate in large environments andcould cause routing inconsistencies.

    RIP has no concept of network delays and link costs. Routing decisions are based on hop counts.The path with the lowest hop count to the destination is always preferred even if the longer path hasa better aggregate link bandwidth and less delays.

    RIP networks are flat networks. There is no concept of areas or boundaries. With the introduction ofclassless routing and the intelligent use of aggregation and summarization, RIP networks seem tohave fallen behind.

    Some enhancements were introduced in a new version of RIP called RIP2. RIP2 addresses theissues of VLSM, authentication, and multicast routing updates. RIP2 is not a big improvement over

    RIP (now called RIP 1) because it still has the limitations of hop counts and slow convergence whichare essential in todayslarge networks.

    OSPF, on the other hand, addresses most of the issues previously presented:

    With OSPF, there is no limitation on the hop count. The intelligent use of VLSM is very useful in IP address allocation. OSPF uses IP multicast to send link-state updates. This ensures less processing on routers that are

    not listening to OSPF packets. Also, updates are only sent in case routing changes occur instead ofperiodically. This ensures a better use of bandwidth.

    OSPF has better convergence than RIP. This is because routing changes are propagatedinstantaneously and not periodically.

    OSPF allows for better load balancing. OSPF allows for a logical definition of networks where routers can be divided into areas. This limits

    the explosion of link state updates over the whole network. This also provides a mechanism foraggregating routes and cutting down on the unnecessary propagation of subnet information.

    OSPF allows for routing authentication by using different methods of password authentication. OSPF allows for the transfer and tagging of external routes injected into an Autonomous System.

    This keeps track of external routes injected by exterior protocols such as BGP.

    This of course leads to more complexity in the configuration and troubleshooting of OSPF networks.Administrators that are used to the simplicity of RIP are challenged with the amount of newinformation they have to learn in order to keep up with OSPF networks. Also, this introduces more

    overhead in memory allocation and CPU utilization. Some of the routers running RIP might have tobe upgraded in order to handle the overhead caused by OSPF.

  • 5/23/2018 Ccna Lab Manual

    52/109

    What Do We Mean by Link-States?

    OSPF is a link-state protocol. We could think of a link as being an interface on the router. The stateof the link is a description of that interface and of its relationship to its neighboring routers. Adescription of the interface would include, for example, the IP address of the interface, the mask, thetype of network it is connected to, the routers connected to that network and so on. The collection ofall these link-states would form a link-state database.

    Shortest Path First Algorithm

    OSPF uses a shorted path first algorithm in order to build and calculate the shortest path to allknown destinations. The shortest path is calculated with the use of the Dijkstra algorithm. Thealgorithm by itself is quite complicated. This is a very high level, simplified way of looking at thevarious steps of the algorithm:

    1. Upon initialization or due to any change in routing information, a router generates a link-stateadvertisement. This advertisement represents the collection of all link-states on that router.

    2. All routers exchange link-states by means of flooding. Each router that receives a link-state updateshould store a copy in its link-state database and then propagate the update to other routers.

    3. After the database of each router is completed, the router calculates a Shortest Path Tree to alldestinations. The router uses the Dijkstra algorithm in order to calculate the shortest path tree. Thedestinations, the associated cost and the next hop to reach those destinations form the IP routingtable.

    4. In case no changes in the OSPF network occur, such as cost of a link or a network being added ordeleted, OSPF should be very quiet. Any changes that occur are communicated through link-statepackets, and the Dijkstra algorithm is recalculated in order to find the shortest path.

    The algorithm places each router at the root of a tree and calculates the shortest path to eachdestination based on the cumulative cost required to reach that destination. Each router will have itsown view of the topology even though all the routers will build a shortest path tree using the samelink-state database. The following sections indicate what is involved in building a shortest path tree.

    OSPF Cost

    The cost (also called metric) of an interface in OSPF is an indication of the overhead required tosend packets across a certain interface. The cost of an interface is inversely proportional to thebandwidth of that interface. A higher bandwidth indicates a lower cost. There is more overhead(higher cost) and time delays involved in crossing a 56k serial line than crossing a 10M Ethernet

    line. The formula used to calculate the cost is:

    Cost = 100/Bandwidth in Mbps

  • 5/23/2018 Ccna Lab Manual

    53/109

    OSPF Configuration

    Load IP Routing Intials Prior to Starting

    Task 1Configure OSPF area 0 on R1 advertise its all networks into OSPF use process id 100

    Solution:

    On R1:

  • 5/23/2018 Ccna Lab Manual

    54/109

    R1#

    R1#configure terminal

    R1(config)#router ospf 100

    R1(config-router)#network 10.0.0.0 0.0.0.255 area 0

    R1(config-router)#network 12.0.0.0 0.0.0.255 area 0

    R1(config-router)#exit

    R1(config)#exit

    R1#

    Verification:

    On R1:

    R1#

    R1#show ip protocols

    *** IP Routing is NSF aware ***

    Routing Protocol is "ospf 100"

    Outgoing update filter list for all interfaces is not set

    Incoming update filter list for all interfaces is not set

    Router ID 12.0.0.1

    Number of areas in this router is 1. 1 normal 0 stub 0 nssa

    Maximum path: 4

    Routing for Networks:

    10.0.0.0 0.0.0.255 area 0

    12.0.0.0 0.0.0.255 area 0

    Routing Information Sources:

    Gateway Distance Last Update

    Distance: (default is 110)

    R1#

    Task 2 configure OSPF area 0 on R2 and R3 advertise all the networks use process id 100

    Solution:

  • 5/23/2018 Ccna Lab Manual

    55/109

    On R2:

    R2#

    R2#config terminal

    R2(config)#router ospf 100

    R2(config-router)#network 12.0.0.0 0.0.0.255 area 0

    R2(config-router)#network 23.0.0.0 0.0.0.255 area 0

    R2(config-router)#network 20.0.0.0 0.0.0.255 area 0

    R2(config-router)#exit

    R2(config)#exit

    R2#

    On R3:

    R3#

    R3#configure terminal

    R3(config)#router ospf 100

    R3(config-router)#network 23.0.0.0 0.0.0.255 area 0

    R3(config-router)#network 30.0.0.0 0.0.0.255 area 0

    R3(config-router)#exit

    R3(config)#exit

    R3#

    Task 3Verify Routing tables of all 3 routers and test end-to-end connectivity.

    Verification:

    R1#show ip route

    Codes: L - local, C - connected, S - static, R - RIP, M - mobile,

    B BGP D - EIGRP, EX - EIGRP external, O - OSPF,

    IA - OSPF inter area N1 - OSPF NSSA external type 1,

    N2 - OSPF NSSA external type 2, E1 - OSPF external type 1,

    E2 - OSPF external type 2 i - IS-IS, su - IS-IS summary,

    L1 - IS-IS level-1, L2 - IS-IS level-2 ia - IS-IS inter area,

    * - candidate default, U - per-user static route

    o - ODR, P - periodic downloaded static route,

    + - replicated route

  • 5/23/2018 Ccna Lab Manual

    56/109

    Gateway of last resort is not set

    10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

    O 10.0.0.0/24 is directly connected, Ethernet0/0

    L 10.0.0.1/32 is directly connected, Ethernet0/0

    12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

    C 12.0.0.0/24 is directly connected, Serial1/0

    L 12.0.0.1/32 is directly connected, Serial1/0

    20.0.0.0/24 is subnetted, 1 subnets

    O 20.0.0.0 [120/1] via 12.0.0.2, 00:00:24, Serial1/0

    23.0.0.0/24 is subnetted, 1 subnets

    O 23.0.0.0 [120/1] via 12.0.0.2, 00:00:24, Serial1/0

    30.0.0.0/24 is subnetted, 1 subnets

    O 30.0.0.0 [120/2] via 12.0.0.2, 00:00:24, Serial1/0

    R1#

    R1#

    R1#ping 23.0.0.2

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 23.0.0.2, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 8/10/16 ms

    R1#ping 20.0.0.2

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 20.0.0.2, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/8 ms

    R1#ping 30.0.0.3

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 30.0.0.3, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 12/16/20 ms

    R1#

    On R2:

    R2#

    R2#show ip route

  • 5/23/2018 Ccna Lab Manual

    57/109

    Codes: L - local, C - connected, S - static, R - RIP, M - mobile,

    B - BGP, D - EIGRP, EX - EIGRP external, O - OSPF,

    IA - OSPF inter area , N1 - OSPF NSSA external type 1,

    N2 - OSPF NSSA external type 2

    E1 - OSPF external type 1, E2 - OSPF external type 2

    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1,

    L2 - IS-IS level-2 , ia - IS-IS inter area,

    * - candidate default, U - per-user static route

    o - ODR, P - periodic downloaded static route,

    + - replicated route

    Gateway of last resort is not set

    10.0.0.0/24 is subnetted, 1 subnets

    O 10.0.0.0 [120/1] via 12.0.0.1, 00:00:14, Serial1/0

    12.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

    C 12.0.0.0/24 is directly connected, Serial1/0

    L 12.0.0.2/32 is directly connected, Serial1/0

    20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

    C 20.0.0.0/24 is directly connected, Ethernet0/0

    L 20.0.0.2/32 is directly connected, Ethernet0/0

    23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

    C 23.0.0.0/24 is directly connected, Serial1/1

    L 23.0.0.2/32 is directly connected, Serial1/1

    30.0.0.0/24 is subnetted, 1 subnets

    O 30.0.0.0 [120/1] via 23.0.0.3, 00:00:27, Serial1/1

    R2#

    R2#

    R2#ping 10.0.0.1

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/12 ms

    R2#ping 30.0.0.3

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 30.0.0.3, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 8/8/12 ms

    R2#

  • 5/23/2018 Ccna Lab Manual

    58/109

    On R3:

    R3#R3#show ip route

    Codes: L - local, C - connected, S - static, R - RIP, M - mobile,

    B BGP, D - EIGRP, EX - EIGRP external, O - OSPF,

    IA - OSPF inter area, N1 - OSPF NSSA external type 1,

    N2 - OSPF NSSA external type 2, E1 - OSPF external type 1,

    E2 - OSPF external type 2, i - IS-IS, su - IS-IS summary,

    L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

    , * - candidate default, U - per-user static route

    o - ODR, P - periodic downloaded static route, + - replicated route

    Gateway of last resort is not set

    10.0.0.0/24 is subnetted, 1 subnets

    O 10.0.0.0 [120/2] via 23.0.0.2, 00:00:06, Serial1/0

    12.0.0.0/24 is subnetted, 1 subnets

    O 12.0.0.0 [120/1] via 23.0.0.2, 00:00:06, Serial1/0

    20.0.0.0/24 is subnetted, 1 subnets

    O 20.0.0.0 [120/1] via 23.0.0.2, 00:00:06, Serial1/0

    23.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

    C 23.0.0.0/24 is directly connected, Serial1/0

    L 23.0.0.3/32 is directly connected, Serial1/0

    30.0.0.0/8 is variably subnetted, 2 subnets, 2 masks

    C 30.0.0.0/24 is directly connected, Ethernet0/0

    L 30.0.0.3/32 is directly connected, Ethernet0/0

    R3#

    R3#

    R3#ping 12.0.0.1

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 12.0.0.1, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/20 ms

    R3#ping 20.0.0.2

  • 5/23/2018 Ccna Lab Manual

    59/109

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 20.0.0.2, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 4/8/12 ms

    R3#ping 10.0.0.1

    Type escape sequence to abort.

    Sending 5, 100-byte ICMP Echos to 10.0.0.1, timeout is 2 seconds:

    !!!!!

    Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/20 ms

    R3#

    Task 4 Configure all three routers in such manner that they send updates through only required

    interfaces

    On R1

    R1#config terminal

    R1(config)#router ospf 100

    R1(config-router)#passive-interface ethernet 0/0

    R1(config-router)#exit

    R1(config)#exit

    R1#

    On R2:

    R2#config terminal

    R2(config)#router ospf 100

    R2(config-router)#passive-interface ethernet 0/0

    R2(config-router)#exit

    R2(config)#exit

    R2#

    On R3:

    R3#config terminal

    R3(config)#router ospf 100

    R3(config-router)#passive-interface ethernet 0/0

  • 5/23/2018 Ccna Lab Manual

    60/109

    R3(config-router)#exit

    R3(config)#exit

    R3#

    Verification:

    On R1:

    R1#

    R1#show ip protocols

    *** IP Routing is NSF aware ***

    Routing Protocol is "ospf 100"

    Outgoing update filter list for all interfaces is not set

    Incoming update filter list for all interfaces is not set

    Router ID 12.0.0.1

    Number of areas in this router is 1. 1 normal 0 stub 0 nssa

    Maximum path: 4

    Routing for Networks:

    10.0.0.0 0.0.0.255 area 0

    12.0.0.0 0.0.0.255 area 0

    Passive Interface(s):

    Ethernet0/0

    Routing Information Sources:

    Gateway Distance Last Update

    Distance: (default is 110)

    R1#

    Task 5 check ospf neighbors on all the router with show ip ospf neighbor.

    Verification:

    On R1:

    R1#

    R1#show ip ospf neighbor

    Neighbor ID Pri State Dead Time Address Interface

    23.0.0.2 0 FULL/- 00:00:36 12.0.0.2 Serial1/0

    R1#

    On R2:

  • 5/23/2018 Ccna Lab Manual

    61/109

    R2#

    R2#show ip ospf neighbor

    Neighbor ID Pri State Dead Time Address Interface

    30.0.0.3 0 FULL/- 00:00:38 23.0.0.3 Serial1/1

    12.0.0.1 0 FULL/- 00:00:38 12.0.0.1 Serial1/0

    R2#

    On R3:

    R3#show ip ospf neighbor

    Neighbor ID Pri State Dead Time Address Interface

    23.0.0.2 0 FULL/- 00:00:34 23.0.0.2 Serial1/0

    R3#

    Explanation:

    In task 1 we have been asked to advertise network in OSPF un likely in EIGRP we give router eigrp

    and AS number in EIGRP configuration. But in ospf we have to give process id. When we have to

    advertise networks in ospf we have to use wild-card bits.

    The best way to calculate wild-card bits for any network is to subtract subnet-mask from broadcast

    address.

    For e.g.

    Wildcard bit for 150.1.1.0/24 will be

    255.255.255.255

    - 255.255.255.0

    = 0.0.0.255

    So if you want to advertise network 150.1.1.0/24 in ospf u can advertise with network 1501.1.0 0.0.0.255

    area 0

    Switch Introduction

  • 5/23/2018 Ccna Lab Manual

    62/109

    Hubs vs. Switches

    Prior to switches, Hubs were the standard for connecting devices on a local area network (LAN).The problem with hubs was that everything that went through them had to share the bandwidth ofthe link. Bandwidth was wasted because all traffic was sent to all devices, and there were a lot ofcollisions because the hub didnt do anything to prevent them. A switch fixes these problems.

    What do switches do?

    Here are some facts about switches that you should know:

    Switches work at Layer 2 of the OSI model, not Layer 1 like a hub Switches switch Ethernet frames Switches dont look at IP address information, only Ethernet MAC addresses Switches keeps a table of all MAC addresses traversing the switch and what port they are on (this

    table is called the bridge forwarding table or CAM table) Switches only sends traffic to the devices that are the destination for that traffic, saving bandwidth Each device connected to the switch gets the full bandwidth of the switch port because the switch

    prevents collisions

    Flooding

    Now that you know that the switch has the bridge forwarding table and uses that to intelligently sendtraffic, a common question is, what if the destination MAC address for the traffic that the switchreceives is not in the bridge forwarding table? What does the switch do with that Ethernet frame?The answer is that the switch will flood that frame out all ports on the switch. The switch will thenmonitor the traffic for the response from that frame and see what device, on what port, responded tothat flooded frame. That information will be put in the bridge forwarding table so that, next time, theswitch wont have to flood that traffic

    Port speed & Duplex

    Of particular importance when it comes to switches are port speed and duplex. The speed of a portcan be set to 10Mb, 100Mb, or 1000Mb (1GB), or Auto negotiate, depending on what the sw